D3 application won't start

Get your trial key

Live community: https://discord.gg/s39XdMV
New user ? Check guides​ or ask the discord bot

yolo88
Joined: 02/23/2016 - 20:41
Tue, 02/23/2016 - 21:05 #1
Bot Version: 
2.01
Release Type: 
Public
Sequence Used: 
N/A
Sequence Settings: 
N/A
Custom Script Used: 
N/A
Custom Pickit Used: 
N/A
FastMode Settings: 
N/A
Avoidance Settings: 
N/A
Frequency Of Apparition: 
100%
Issue Description: 
rosbot run fine but the game just won't start.when i try to run rosbot it launch "Diablo III.exe" and splash screen appear but after the splash screen disappear "Diablo III.exe" also gone(in Task Manager.i already tried to reinstall rosbot and delete rosbot folder in "My document" but still no luck even after waiting for more than 10 minutes the game still won't launch.it didn't happen in previous version of rosbot and if i started the game through battle.net client it start normally..i use rosbot in a win 7 64bit VM using VMWare 12,my system use win 10
Reproduction procedure: 
run rosbot.exe
Logs: 
no logs
cotinhabrx
Joined: 02/01/2016 - 04:32
Tue, 02/23/2016 - 21:10

had the same problem,did this

1) Open command prompt as administrator
2) cd \users\<whatever the new username is>\documents\diablo III
3) edit D3Prefs.txt and set DisplayModeWindowMode "1"

and give full permissions over my d3 folder to the new user,working fine right now.


yolo88
Joined: 02/23/2016 - 20:41
Tue, 02/23/2016 - 21:21

its my first run so there are no "Diablo III" folder in "random username\documents" and if i copied "Diablo III" folder from my document to those folder it still won't run even with your setting


yolo88
Joined: 02/23/2016 - 20:41
Tue, 02/23/2016 - 21:53

well,finally the game can run.all i do is moving my Diablo 3 game folder out from "program files(x86)" to c:\ drive and change rosbot diablopath config


niks90
DONATOR
Joined: 05/11/2014 - 02:50
Mon, 01/02/2017 - 20:03 (Reply to #4)

Your solution works!! Thank you!


camap_14
DONATOR
Joined: 06/12/2015 - 01:56
Tue, 02/23/2016 - 23:28

thanks yolo88. your solution work for me.


Laama666
DONATOR
Joined: 12/31/2014 - 05:16
Wed, 02/24/2016 - 10:01

I've tried all proposed solutions but Ros-Bot still won't start Diablo III. Tried giving all permissions to this new user for all D3 folders but it didn't help. Tried moving D3 game folder out from C:\Program Files (x86) but it didn't help. Deleted all RB folders and did clean install - didn't help. I'm using Win7 Pro x64 SP1.

Not getting any errors and I can see Diablo III.exe (under new user) in Windows Task Manager but it's using only 120K memory (if I start D3 manually it's using over 1000000K memory):


ChunSnape
Joined: 10/28/2015 - 19:22
Wed, 02/24/2016 - 10:16

Absolutly same here


TicketToBase
Joined: 02/23/2016 - 22:25
Wed, 02/24/2016 - 11:21

Well i´m new but i got the same problem over here :/ i also did all the steps and followed all solutions i could find. But the game still won´t start 


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Wed, 02/24/2016 - 11:46

Please try running your game as the limited user created by the bot. Shift + right click on the game executable + run as. Username and password are located in you global settings file

Let me know if this works


NO support by private message.

Support must go through forums
Support - Beta

Laama666
DONATOR
Joined: 12/31/2014 - 05:16
Wed, 02/24/2016 - 12:08 (Reply to #10)

Please try running your game as the limited user created by the bot. Shift + right click on the game executable + run as. Username and password are located in you global settings file

Let me know if this works

This method worked. Thank you!


iamsoskill
Joined: 01/22/2016 - 13:03
Wed, 02/24/2016 - 13:03 (Reply to #10)

My rosbot won't even create a user ): On desktop it's fine, on laptop it doesn't.  Any help?


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Wed, 02/24/2016 - 14:25 (Reply to #12)

My rosbot won't even create a user ): On desktop it's fine, on laptop it doesn't.  Any help?

You can just create it by hand and then copy/paste username/password in the globalsettings file


NO support by private message.

Support must go through forums
Support - Beta

iamsoskill
Joined: 01/22/2016 - 13:03
Wed, 02/24/2016 - 15:11 (Reply to #13)

Hmm, how do I create one? Win10 has this new fancy account creation procedure that I hate, which is not at all the same as Win7 one ):

Also, do you know what is causing it to not auto create? :)


ziplocmd
Joined: 12/14/2015 - 19:12
Wed, 02/24/2016 - 15:24

creating one didnt help. i tried shift right clicking run as using the user/pw in global ini file and i get access denied. etc etc
rosbot cant launch d3 and gets access denied error.
not sure if rosbot is actually or correctly creating a new limited user because if i look in users folder there is no other users that were created etc
gave all permissions to all d3 folders
added 2 strings in hkey etc

still wont work. rip

running windows 10


speed-kota
Joined: 01/30/2016 - 01:14
Wed, 02/24/2016 - 18:25

need ros-bot for dummies........HELP,  tried all above and in all forums, not working


123Affe321
Joined: 11/30/2016 - 14:17
Tue, 12/06/2016 - 23:23

idk i buyed this shit and nothing works after i started the bot one time. Just try to get my money back. Bs bot.


AcidAlchamy
Joined: 07/15/2017 - 16:45
Wed, 07/19/2017 - 07:07

Yeah Im also a bit stuck when its coming to the VM. Tried everything mentioned above but continue to get a greyed out screen with mouse logo changed but the screen is semi froze and when i toggle Esc it exist' the window. Not sure what else to try. tried changing the compatibility to  see what else I could run it as. considering changing my VM install into W10 and trying my luck their. Anyone else manage to get their stuff working?


- YT - FB - IG -
#AcidAlchamy
@AcidAlchamy
Considering starting my scripting with this bot...

Advertisements

Advertisements