Can't log into Diablo 3

Get your trial key

Live community: https://discord.gg/s39XdMV

​New user ? Check guides​ or ask the discord bot

A new patch is out. Please wait for an update

teotuf
Joined: 12/21/2015 - 23:17
Wed, 02/24/2016 - 00:28 #1
Bot Version: 
2.01
Release Type: 
Public
Sequence Used: 
N/A
Sequence Settings: 
N/A
Custom Script Used: 
N/A
Custom Pickit Used: 
N/A
FastMode Settings: 
N/A
Avoidance Settings: 
N/A
Frequency Of Apparition: 
100%
Issue Description: 
When starting D3 using ros-bot, the game loads onto main screen. But when I put in the username and password it gives me an error saying "Your login information is incorrect. Please try again. (Code 3)"

When I run D3 from any other account (i.e. when user is not the random letter/number generated by ros-bot, I am able to login fine. I suspect it's a permission issue with ProgramData folder or the main Diablo III folder, so I gave full permission to the limited user to those directories - but it doesn't seem to solve the problem.
Reproduction procedure: 
Restart/Give permission/all the normal power user stuff
Logs: 
N/A
damandd
MODERATOR
Joined: 01/04/2015 - 16:46
Wed, 02/24/2016 - 00:54

Try ending the Agent.exe in Task Manager then deleting the Blizzard Entertainment folder usually located in C:\ProgramData after try to do those 2 things relaunch and see if it works.


Please vote here to have a nearby Pylon or Shrine take priority.
https://www.ros-bot.com/suggestions/prioritize-pylons-396644

teotuf
Joined: 12/21/2015 - 23:17
Wed, 02/24/2016 - 06:52

I did. It caused battle.net to "reinstall" but still resulted in the same error.

I am trying to run battle.net to login as the new user using shift click, but apparently it has a generated password so I can't actually even do that manually.

Also I have tried this both in windows 10 64bit native and in vmware. Both showed the same behaviour with the same code 3 error.

I vaguely remember a few days ago I had similar problem with a manually created limited user but got fixed when I logged onto that user once in windows.

------------------------------------------
Edit: I was able to get around this problem by changing the Local User at the bottom of global settings in RoS-Bot to a manually created user. Then I logged into the game manually via battle.net and started the bot after that. Interestingly starting the game from RoS-Bot under this manually created account still results in an code 3 login error despite the fact that I can login manually.


teotuf
Joined: 12/21/2015 - 23:17
Wed, 02/24/2016 - 06:52

I did. It caused battle.net to "reinstall" but still resulted in the same error.

I am trying to run battle.net to login as the new user using shift click, but apparently it has a generated password so I can't actually even do that manually.


lordkahuna
Joined: 02/16/2016 - 18:22
Mon, 04/18/2016 - 15:33

Hello..


I'm having the same problem starting the game and try to log appears "error 3" already deleted the Blizzard Entertainment folder as mentioned above but the error remains .. how can try to solve this?!? I thank

Sorry but the English used the google translator :)


PiroxTester
MODERATOR
Joined: 05/09/2014 - 20:40
Tue, 04/19/2016 - 03:20

If you are entering your Username(Email) and your PW and it says that Username or PW is Wrong, than you did something wrong.
Check your Langue on your Keyboard and switch it with ALT+SHIFT if necessary.

Did you checked the Bnet Forum? Because that's not a RoS-Bot related Problem.
http://us.battle.net/d3/en/forum/topic/5978430436

Ang3r
Joined: 10/23/2015 - 12:59
Mon, 08/22/2016 - 15:33

**Edit**

My bad, it turns out to really be some weird D3 problem. After changing the password (although the first one was still working) I was able to logon

Case closed :)

Hello

I have the same issue here. Since I am copy/pasting the user name / password I am sure it is not the D3 issue. Also, if I start D3 directly it will work great.

Is there any way to activatge the old RosBot behaviour?

I am talking about starting the d3 normal way and after that starting the rosbot, and he will just "attach" itself on the existing process?

 


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Mon, 08/22/2016 - 15:59

Remove authenticator
Log into the game
Readd the authenticator


NO support by private message.

Support must go through forums
Support - Beta

Advertisements

Advertisements