[2.01] Game not starting issue

Get your trial key

Live community: https://discord.gg/s39XdMV

New user ? Check guides​ or ask the discord bot

Topic locked
Last post
sword16
DONATOR
Joined: 09/12/2014 - 07:03
Mon, 04/03/2017 - 08:23

The key press simulation for 0 was not successful.
   at ‭‫‭‎‮‏‫‏‏‪‭‭‬​‬‎​‍‍​‭‪‪‭‬‮.‮​‎‌‫‫‌‏​‬‭‬‬‬‬‮‪​‫‬‌‬‮(‪​‮‬‭‏‏‏‮‭​‏‎‏‏‬‎‫‮‫‮​‮‍‮ )
   at ‪‌‪‎‬‫‭‫‎‪‌‬‏‍‏‮‮‍‭‏‬‬‮​‎‪‮.‪‍‭​‭‎‪​‌‍‬‌‮​‪‌‎‎‍‌‮‪‮‫‬‏‮(Int32 )
   at ‭‍‮​‪‮‌‍‮‫‬‏‏‎‎‏‬‎‮‬‭‪‭​​‏‪‮.‪‎​‍‎‍‬‫‮‏‮‎‭‫​‌‏‎‬‍‭‪‪‏‎‮‮(Boolean )
   at  rd^VI=ggrF{r'\]R\.p^\.A"ea".‬‌​‭‮​‭‌‬‎‬‭‫‏‪‪‍‬‭‌‬‫‌‌‮.‬‍‌‬‫‭‭‍​‏‏‬‍‪‏‬‏‭‎‌‌‎​‌‮()
   at ‏‎‎‍‭‪‭‫‫​‭‎‏​‌‬‪‌‭‭‪‍‏‎‏‮.‌‍‌‭‬‎‮‍‮‏‍‬‌‏‍‫‍‬‬‫‪‭‎‪‮.‪‎‭‪‍‌‍​‬‪‌‌​‪‎‎‬‬‪‌‍‮‏‮()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()


rze
MODERATOR
Joined: 03/04/2017 - 06:12
Mon, 04/03/2017 - 09:23

Did you set up ingame hotkeys?

See the guide https://www.ros-bot.com/guide/getting-started


User support goes only through the forums
- FAQ: https://www.ros-bot.com/guide/faq
 

PookyPer
DONATOR
Joined: 12/15/2015 - 14:22
Wed, 04/05/2017 - 12:37

Edit: Ok nevermind Im just blind and/or stupid


dilios247
DONATOR
Joined: 02/27/2015 - 04:09
Tue, 04/11/2017 - 05:36

Anyone else unable to get d3 to load since updating to 2.118 Early Access.

When I downgraded back to one version before then d3 launches again


Alenari
DONATOR
Joined: 09/12/2015 - 02:05
Tue, 04/11/2017 - 05:42 (Reply to #105)

I'm experiencing this as well.


Blacklisted31
Joined: 03/06/2015 - 16:46
Tue, 04/11/2017 - 15:40 (Reply to #106)

Yeah, currently have the same problem.. Didn't save 2.114 so I'm pretty boned until this gets fixed. XD


dfat
Joined: 03/10/2016 - 05:49
Sat, 04/15/2017 - 16:44

Would not initialise.
rebooted-nothing. Then I moved the Diablo III from x86 to c drive, changed pathing and also deleted my rosbot documents.
Booted up again. started rosbot and it remade all files. Set up password in global along with other values I had before n boom worked; took about 4 hours of reading forums n tinkering around(computer novice by all measures) but it worked! =)

Hopefully this steers some other lost soul. gl


Leather12394
DONATOR
Joined: 09/17/2015 - 05:21
Tue, 04/25/2017 - 20:25

While I didn't go through all the steps @dfat did, I simply moved my installation of Diablo 3 from the Desktop to the root on C and entered the new path in RoSBot Global.ini and my error was resolved.

The error was something about the directory being wrong. For those that see this error try moving your D3 installation.
Windows 10 Pro VM


darkblade210
Joined: 04/26/2017 - 12:24
Wed, 04/26/2017 - 17:53

game getting into showing the bot UI but then throwing this error any help would be appreicated

Object reference not set to an instance of an object.
   at ‪‭‎‫‮​‪‭‍‍‭‌‎‭‫‎‎‬‏‏‬‭‏‬‎‬‌‮‮.‌‍‬‬‌‭‎‌‎​‫‏‫​‍‫​‪‌‮‌​‍‬‍‫‍‫‮(‬‎​​‮‮‭‪‍‭​‌‭‭‮‭​‌‬‎‌‭‫‫‏‍‌‮‮ , LevelArea , ‍‮‭‫‮‎‍​‌‌‫​‫‫‏‪‪‏‫‏‪‌‌‬‭‬‮‮ , ‍‮‭‫‮‎‍​‌‌‫​‫‫‏‪‪‏‫‏‪‌‌‬‭‬‮‮ , Boolean )
   at ‪‭‎‫‮​‪‭‍‍‭‌‎‭‫‎‎‬‏‏‬‭‏‬‎‬‌‮‮.‏‮‏‍‎‍‌‍‍‬‍​‭‎‍​‌‎‏‍​‮‮(‬‎​​‮‮‭‪‍‭​‌‭‭‮‭​‌‬‎‌‭‫‫‏‍‌‮‮ , ‪‌‭‪‪‪‪‮‪​‍‏‏‌‫‮‍‮‪‮‮‭‬​‮ , ‍‮‭‫‮‎‍​‌‌‫​‫‫‏‪‪‏‫‏‪‌‌‬‭‬‮‮ , ‍‮‭‫‮‎‍​‌‌‫​‫‫‏‪‪‏‫‏‪‌‌‬‭‬‮‮ )
   at ‪‭‎‫‮​‪‭‍‍‭‌‎‭‫‎‎‬‏‏‬‭‏‬‎‬‌‮‮.​​​‍‫‫‪‫‏‏‭‍‮‭‪‌‬‬‍‏‬​‏‫‬‬‮()
   at ‪‭‎‫‮​‪‭‍‍‭‌‎‭‫‎‎‬‏‏‬‭‏‬‎‬‌‮‮.‍‏‭‏‫‏‫‬‫‫‮‫‮‎‫‭‪‫‌‎‌‎‏‌‭‮(Boolean )
   at VuDk0/VtHv>LLXWOV2?;}}\[6\&.‌‎‭‪‪​‬‎‏‭‮‮‌‫‮​‌‍‭‬‮‌‮‏‮‬‫‪‮.​‪‫‫‌‍‫‏‬‎‪‫‏‌‬‮‎‌‏​‪‭‫‫‫‭‎‮()
   at ‎‏‏​‪‌‏‫‫‫‏‪‫‎‮​‮‫‭‮​‭‏‏‭‍‫‮.‬‫‫‫‏​‪‬‮‭‎‭‫‍‬‌​‌‮‮‪‫​‎‌‍‮.‍‏‎‫​​‮‭‌‪‮‎​‌​‮‭‏‌‏‫‏‫‮‎‏‭‫‫‮()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()


kelesch429
Joined: 06/02/2016 - 17:47
Tue, 07/04/2017 - 17:56

if i start the bot diablo3 wont open for me can someone help me please?


WalkinTall
Joined: 08/07/2016 - 21:28
Thu, 07/06/2017 - 08:05

So my Bot is stuck at 'Initializing Ros-Bot'.

It ran pretty good. I openend the Ros-Bot.exe and it automatically started Diablo3. Then I just had to press Start Botting.
Yesterday I forgot to switch a script (I got premium license) and had to end Diablo3 and the bot. I did it via task manager as I forgot the F6 function (last time I botted was a year ago). So the bot ran perfectly for 4 days now.

I then changed scripts and started again; forgot gambling options tho. I stopped it again. Afterwards I couldn't start the .exe because 'license was already being used'. I went to this homepage and pressed 'Stop' in 'bot license options'. Afterwards I unpaused it and wanted to bot again. Now it does not start the game anymore. Not at all. When I start it manually and start the bot, it will automatically shut D3 down and do nothing.

I then tried it with the different user (also changed my Global.ini accordingly) doesn't work.
Downloaded the bot again - doesn't work.
Changed my Diablo folder to somewhere else and changed it in Global.ini - doesn't work.

Now I'm here :-D

Thanks


rake
DONATOR
Joined: 03/04/2015 - 16:36
Thu, 07/06/2017 - 09:19 (Reply to #112)

The most common cure-all for issues like that is usually just to delete <my documents>\Ros-Bot forlder and run the bot again.


goalguy02
Joined: 02/04/2017 - 21:08
Sun, 07/09/2017 - 19:41 (Reply to #113)

Same with me


bullfighter
Joined: 10/05/2015 - 19:20
Wed, 07/19/2017 - 17:16

same problem here, deleted rosbot folder in my documents, nothing happends when trying to start Ros-Bot 

deleted everything did a fresh install and still same problem


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Wed, 07/19/2017 - 17:28 (Reply to #115)

Any event in Windows Event Logs ?


NO support by private message.

Support must go through forums
Support - Beta

bullfighter
Joined: 10/05/2015 - 19:20
Wed, 07/19/2017 - 17:58 (Reply to #116)

Activation of app Microsoft.Windows.Apprep.ChxApp_cw5n1h2txyewy!App failed with error: This app can't be activated by the Built-in Administrator. See the Microsoft-Windows-TWinUI/Operational log for additional information.

 

"guess this is generated from trying to start Ros-Bot"
 


Istaria
Joined: 03/02/2016 - 11:28
Sun, 07/23/2017 - 14:59

Right, this is starting to become irritating.

- Game is on C:
- I have even moved it to Desktop
- Config file - deleted and manually adjusted with my credentials multiple times. Nope.
- RB running from downloads/documents/desktop/root - nothing

Game simply does not start. And what drives me goddamn mad with the troubleshootin is this stupid "Your license is in use" for 10 minutes crap.

I'm really getting annoyed. And advice like "Did you plug it out and plug it in again" or "Reboot your computer" will not be met with good grace or politeness at this point.

What, to sum it up, is the fucking craic?


jab911
Joined: 04/28/2017 - 01:32
Wed, 07/26/2017 - 07:01

<Never mind all fixed, needed to add a command line argument -vsync -window>Hi There, the game launches for me, but the screen is black.  I can hear the music and when I move my mouse I can hear the mouse over sounds on menu buttons.  What can I do to get the game to run properly on startup?


lokilindo
Joined: 02/17/2015 - 14:42
Thu, 07/27/2017 - 03:49

The BoT is stuck at the "Initializing RoS-Bot..." message window. If I delete the "RoS-BoT" folder under Documents. Then some times the first couple of sarts work, but I get jab911's issue with the black screen, when the mouse moves around, I can hear the button's being activated by hovering over them, but can't really see anything. 
 


backwerd
Joined: 10/23/2015 - 00:11
Thu, 07/27/2017 - 21:50

Haven't been able to start the bot for the life of me, the application where you configure the settings doesn't even launch.  Here's what I've tried:
- Using version 2.321
- Extracted scene files successfully after shutting down Battle.Net
- Set full control of local user to Documents/Ros-Bot folder
- ROS folder on Desktop and not in D3 game folder

I'm on Windows 10 Home.  Any ideas I should try?  Kind of at a loss at the moment.


sebflex
Joined: 12/10/2015 - 09:28
Fri, 07/28/2017 - 09:41

After bot starting the window of d3 is black and nothing happens


FOuch1
DONATOR
Joined: 11/26/2014 - 16:21
Fri, 07/28/2017 - 20:58

Downloaded game and trial key cant get the game to start i can start threw the blizzard app and get into d3 but when i start ros bot it deletes it and trys to re open d3 without the app and just goes to a blank screen.. what to do ?


FOuch1
DONATOR
Joined: 11/26/2014 - 16:21
Sat, 07/29/2017 - 13:58

IS THERE ANY WAY TO MAKE THE BOT RUN AFTER YOU HAVE STARTED THE GAME. EVERYTIME I START D3 its good but when i start the bot it shuts down my d3 and then trys to load another d3 but it just goes blank with sound. i need the bot to not run d3 but to run with the d3 that is already running like it used to ? can you help please 


hell_buffalo
DONATOR
Joined: 09/20/2014 - 04:28
Sun, 07/30/2017 - 00:43

"After bot starting the window of d3 is black and nothing happens" i have same problem with this guy, any help?


lamtpham
DONATOR
Joined: 07/04/2015 - 12:14
Thu, 08/03/2017 - 15:36

Just happened today, windows just shut off my rosbot on its own. Now I cant even open rosbot. Windows keep closing it and sending errors to Microsoft. Anyone having the same trouble or have a solution? HELP HELP HELP Thanks


joseph.venetucci
DONATOR
Joined: 06/26/2015 - 12:37
Fri, 08/04/2017 - 21:21

I believe it was after my most recent windows update, the game auto starts but I only get a black screen that does not respond to anything except ESC witch will make it exit. I made an exemption in Avast for the Ros-bot folder, no change, I even turnned off avast but it still wont work. I've tried rebooting, tried extracting the scenes again, deleting the bot folder and reloading it, still can't run the bot.


Tuck
DONATOR
Joined: 05/18/2015 - 10:51
Sun, 08/06/2017 - 09:16

The bot doesnt even work... Can i have a refund just spent 4 hours creating user accounts regsitry files, and so on....

Only thing that helped me launch the game was downgrading my microsoft account to local then putting the account i was on in the .ini file but when i did that the ros-bot didnt have accesss or something to get any pickit files or anything else..

I had respect for this bot a year ago right now it's not worth my time since nobody seems to know anything...


Rokaden16
Joined: 10/19/2015 - 09:59
Tue, 08/08/2017 - 22:00

Just did the new windows update and the bot stopped working. Went ahead and installed the newest version of the bot and still nothing. I click start botting and rosbot just disappears and diablo 3 doesn't start at all.
please fix this!


balduros
Joined: 11/05/2015 - 13:55
Thu, 08/10/2017 - 09:58

Guys for the black screen you can try a thing, edit the RodBotGlobalSettings (my DOcuments folder)

​setting this line like this
 
DiabloCmdLineArguments = set -vsync -window

and

​Overlay = False
 


RosBotUser1
DONATOR
Joined: 10/24/2015 - 23:43
Thu, 08/10/2017 - 14:38

For people having issues with the executable not starting. What I had to do was blow out my Rosbot folder in my my documents. Before doing this you might want to save your .ini files. I didn't mind blowing mine out. After this just launch the exe and let it do it's thing.


chriszhu
DONATOR
Joined: 08/01/2014 - 12:33
Mon, 08/21/2017 - 18:51

Haven't encountered any issues before today, and now I've been getting this error on both of my machines. Tried to unlink a bunch of scripts/pickit in case anything is invalid, does not seem to resolve the issue. Tried deleting the folder in Documents and re-run everything, still getting the same issue.


rfrayer
DONATOR
Joined: 02/24/2015 - 13:17
Sat, 08/26/2017 - 07:32 (Reply to #132)

This is a seporate issue caused bu a serverside problem, I started a propper thread for it just a few minutes ago. We cant include logs because in order to create a log the bot actually has to start.

tommass
Joined: 08/29/2017 - 04:02
Tue, 08/29/2017 - 05:34

Hi.

Is it work on d3 without RoS addon?


smolf
Joined: 03/17/2016 - 16:04
Tue, 09/05/2017 - 08:51

i got black screen?


joseph.venetucci
DONATOR
Joined: 06/26/2015 - 12:37
Sun, 09/17/2017 - 03:10

 I have windows 10 64 bit. When I try to launch the game through the bot I only get a black screen that will not respond to anything but ESC whcih exits the screen. I have tried adding the folder to the exempt list for AVAST. I have been meesing with this a while trying to follow what people did in the forums but nothing seems to work.


mr.testem
DONATOR
Joined: 07/06/2015 - 13:19
Sat, 10/14/2017 - 06:11

Guys, 

I click ros-bot excecution file. Ros-bot window pops up. And it starts Diablo itself. But as soon as Diablo is started, I cannot do anything with the system. I cannot enter email and password. I just do not see anything in these text boxes, although I press buttons. I also, cannot switch to another window, using Alt+Tab. It seems the system hangs, but mouse pointer, yes, I can see it. 
I tried it several times. The same result. I disabled my antivirus. The same result. I am using Windows 10. Bot version is 2.326

What to do? Please help.


yasmeen_
Joined: 07/04/2017 - 22:30
Sat, 10/14/2017 - 18:59 (Reply to #137)

I'm not an expert but.. did you config your D3prefs.txt?

mrangle
Joined: 01/23/2016 - 15:06
Sun, 10/22/2017 - 15:37

I am having the same issue as the Previous submitter, but i just get a black screen with only sound.  I can run the game fine without ros-bot, but when i execute ros-bot crashes it.


mrangle
Joined: 01/23/2016 - 15:06
Sun, 10/22/2017 - 15:37

I am having the same issue as the Previous submitter, but i just get a black screen with only sound.  I can run the game fine without ros-bot, but when i execute ros-bot crashes it.


rosbot83
Joined: 10/22/2017 - 06:31
Sun, 10/22/2017 - 19:41

Hi, 
When I launch RoS-Bot it loads and seems to load everything else under the random created user. The D3 splash screen comes up but then I get a black screen which does not change until I ALT-F4 out. 

I tried having D3 in the lobby and then starting RoS-Bot but it closes D3 and starts it again but getting stuck on the black screen.

Any ideas?

EDIT:
This worked for me:

Guys for the black screen you can try a thing, edit the RodBotGlobalSettings (my DOcuments folder)

​setting this line like this
 
DiabloCmdLineArguments = set -vsync -window

and

​Overlay = False


Osna1337
Joined: 05/07/2015 - 16:31
Fri, 11/03/2017 - 17:05

Hes logging in now, starts the game, then leaves the game and so on. any solutions?


Coldi
Joined: 10/29/2015 - 04:20
Tue, 11/14/2017 - 12:58

Hi.
I start Botting and the he open automatic Diablo. Than i have only a black screen. Can anyone help me. Before 2 month it works very well


NumNuts1
Joined: 02/18/2017 - 08:33
Sun, 11/19/2017 - 18:34

Bot has been running for the past 12hrs, I stopped the bot to change rift settings and it crashed. Restarted everything, Bot then asked me for diablo folder, first got black screen. Re-downloaded bot and now it will not launch the game.

Any ideas?


coreuploader
Joined: 08/28/2017 - 02:11
Tue, 11/21/2017 - 08:58

bot was working past 5 hours, but now when I tried to start ROS, diablo 3 shows splash screen then exit. But ROS bot is running. No error logs found. Tried restart PC, redownload ROS or delete ROS folder in documents. Still not working


sneasal
Joined: 12/09/2015 - 06:48
Fri, 11/24/2017 - 03:03

I have the  same problem,,

Pls fix it


whatup67555
Joined: 11/23/2017 - 10:54
Fri, 11/24/2017 - 15:56

   at ‫‍‍‮‪‪‫‎‌‌‏‫‫‭‎​‌​‭‫‎‬‭‏​‪‌‮.‮‪‎‭‎‏‫‍‎‎‭‪‪‭‍‬‫‪‎‏‮.‎​‮‬​‬‬​‪‫‏‪‬‍‬‮‏‫‎‮‏‮‎‍‍‍‌‮‫‮()
   at ‪​‌‪‍‬‫‮​‌‭​‭‍‭‪‮‍‪‍‫​‍‪‫‮.​‪‍​‎‫‎‏‪‮‪‍​‍‪‎‏‎‎‬‌‭‮()
   at ‪​‌‪‍‬‫‮​‌‭​‭‍‭‪‮‍‪‍‫​‍‪‫‮.​‬‍‏‬‏‎‫‎‫‪‬‮‌‎​‭‌‫‮‬‮‌‏‮‬‮(Boolean )
   at <S|EdHgd8H>AU3'"au"?~xX\]!.‪‏‎‬‎‫‫​‌‎‫‬‪‫‌‌‎​‮‬‏​‬​‮‮‌‮.​‮‌‎‍‭‪‫‫‭‫‫‮​​‌‬‌‌‮‍‪​‎‎​‮()
   at ‮‌‪‍​‪‌‫‍‫‌‪‫‍‭‭‌‌‭‪‍‎‌‍‮‮.‌‏‮‬‭‎‫‬‮‬​‭‌‬‌‫‏‭‌‎‌‭‍‪‎‮.‭‬‭​‮‫‪​‎‌‬​​‍‮‪‫‌‎‌‮‮‫‮‮()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()


wixas88
Joined: 11/19/2016 - 09:17
Mon, 11/27/2017 - 16:14

I have the  same problem,

Bot was working past 12 hours, but now when I tried to start ROS, diablo 3 shows splash screen then exit. But ROS bot is running. No error logs found. Tried restart PC, redownload ROS or delete ROS folder in documents. Still not working.

Finally I have decided to remove the ROS and reinstall it but now there is an error "Ros-bot needs to extract data .... Diablo and Battle.net launcher must be shutdowns ....."

I'm sure the both are shutdown, I do not know what to do. any ideas?

PD: today its all okey!! :D

 


Zmator
Joined: 11/13/2017 - 06:54
Tue, 11/28/2017 - 05:28

Bitte helft mit, den Bot und das Spiel zu starten. siehe Screenshot unten mit Fehlern 
Diablo3 muss gestartet werden - wenn ich D3 gestartet habe und den Botting gestartet habe, wird das Spiel geschlossen und der folgende Fehler ausgegeben 
kann die Anfrage nicht verarbeiten, da der Prozess (4292) beendet wurde. bei system.diagnostics.process.getprocesshandle (int32-Zugriff, booleanthrowifexited) 
auf system.dianostics.process.kill () ... 
mein Betriebssystem ist win 10

Vielen Dankhttps://cdn.ros-bot.com/sites/default/files/u82534-files/1.png


NetPhil
Joined: 12/18/2015 - 13:27
Wed, 11/29/2017 - 18:45 (Reply to #149)

Hi, me my Bitdefender close it with his app protection. I put firewall to off but close it.. When i click on the rosbot app a popoup message appear and tell cant access the file path or...


fredzor
Joined: 11/20/2017 - 13:28
Wed, 11/29/2017 - 21:57

Meu bot não abre, quando executo ele não abre, alguem sabe oque pode ser ?
 


Topic locked

Advertisements

Advertisements