[2.01] Game not starting issue

Get your trial key

3.630 is out: https://www.ros-bot.com/download

Live community: https://discord.gg/s39XdMV

New user ? Check guides​ or ask the discord bot

Topic locked
Last post
Adamosity
Joined: 10/05/2015 - 16:50
Wed, 03/09/2016 - 19:51

Now getting a new issue, Diablo 3 muct be launched, RoS-Bot is force closing Battlenet and Diablo 3 - previously it would then try to open an offline Diable 3. Tried all the above fixes and still at square 1.

Same coded messages as above now being displayed. I'm running this on Parrels 11 desktop VM. Tried a restore, moving Diablo to C: drive, moving RoS bot, adding RoS bot as an exclusion for Avast, deleting all previous RoS bot information and starting again with no joy. Is there a real fix for this yet ?
I've tried everything above and no resolve.


adsdiablobot
Joined: 10/29/2015 - 12:06
Thu, 03/10/2016 - 10:45

I have the same issue as Portegro.  I've also filled out a report here and i've not received any help from the team.

What would be really helpful to rosbot users?  If your team could make an annoucment that "there is no current fix for this" and to come back later. 

OR

the team here at rosbot might announce, "there is a fix for it but, it's complicated ... please follow these steps to resolve:"

please try either one of those ... but, ignoring us after we're paying real money to use this is actually something I take issue with.


haaz
Joined: 10/19/2014 - 06:23
Thu, 03/10/2016 - 14:53 (Reply to #53)

but logging in what the bot open get´s me to a empty character list :/ like i ever started the game. throw battle net and all me character are there, like i have to diffrent user


haaz
Joined: 10/19/2014 - 06:23
Fri, 03/11/2016 - 02:11

haaz
problem i got is that is is shutting the battlenet gui and D3 and start a new one that is stopt to wait for login, why close then it d3 are ready runing??
rude
Not a problem, it's meant to be like that.
The bot needs to start Diablo with a limited user
-----------------

if i login where bot wait for login, i got a empty character list, like i never played the game? any suggestions?

 


 


Raptor
DONATOR
Joined: 10/19/2015 - 20:19
Sat, 03/12/2016 - 17:02

Yes, you are logged into another region. Log into the one you have characters on


Imoiran
DONATOR
Joined: 10/18/2014 - 00:40
Sun, 03/13/2016 - 21:15

Anyone know how to get Ros-Bot to work with Webroot running? I'm not sure it is possible.


Click for ->  Imoiran's Scripts

manu20862086
Joined: 01/30/2016 - 01:00
Mon, 03/14/2016 - 11:17

Hi everyone i dont know what happens ive tried all the solutions but no luck this is the error i get

at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfostartInfo)

at System.Diagnostics.Process.Start()
at zA`<c>QusyWq6V3z/ 

and its long to copy but you get the problem any good soul around there???
 


mtuji88
Joined: 03/12/2016 - 14:29
Mon, 03/14/2016 - 23:19

i having a problem with this message :

System.NullReferenceException: Referência de objeto não definida para uma instância de um objeto.
   em ‏​‏​‫‫‬‪‌‌‫‭‮‭‌‏‪‮‌‭‌‌‭‌‍‮..ctor(CustomSkill settings)
   em zA`<c>QusyWq6V3z\]4\[p:!Pg".​‌‫‌‮‬‭‫‭‏​‭‌‪‮‫‭‭‬‮‬‌‍‎‫‪‏‌‮()
   em zA`<c>QusyWq6V3z\]4\[p:!Pg".‌‪‬​‭‌​‏​​‏‍‪​‎‬‪‫​‬‮‌​‎​‏‮(Object , EventArgs )
   em System.Windows.Forms.Control.OnClick(EventArgs e)
   em System.Windows.Forms.Button.OnClick(EventArgs e)
   em System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   em System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   em System.Windows.Forms.Control.WndProc(Message& m)
   em System.Windows.Forms.ButtonBase.WndProc(Message& m)
   em System.Windows.Forms.Button.WndProc(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

what i have to do ??
 


nextkin
Joined: 03/15/2016 - 14:38
Tue, 03/15/2016 - 21:38

Hi i am having the first problem. I have force binded the key "C" but somewhat it still doesnt work.

it will auto generate a report which i saw and the content is the same that you have posted in "getting started" thread.

PS i am using Win 7 64bits. I don have this problem running ur old version.
 


Portegro
Joined: 11/17/2015 - 03:18
Wed, 03/16/2016 - 07:20

Hello everyone! I solved the problem radically. Since still soon to move to Windows 10, I reinstalled all my apps and now everything works like a clock. I hope that it never will be.


Vesuvan
Joined: 03/20/2016 - 01:54
Mon, 03/21/2016 - 01:44

I have problems where it puts my 3 monitors in stand by mode and I am not able to recover but hear the game running any sugguestion


zalmoxis
DONATOR
Joined: 10/03/2015 - 11:06
Fri, 03/25/2016 - 13:54

hello i have this error when i try to start bot(bot doesent start)
i have windows 10  and all was perfect till i instaled d3helper and ATK  for the lon crusader build
i already put the d3helper folder in the ros bot folder

anyone have any ideea what is it?

regards.
 


almosthere0327
DONATOR
Joined: 07/28/2015 - 19:25
Fri, 03/25/2016 - 20:56

So as of about an hour ago I can not get the game to launch automatically.  Windows 10 VM, windows defender with exception.  No email associated with my account.  It seems that rosbot is not creating the temporary local user, because no name or password are placed in the global settings file and no folder is created in \Users\.  From a previous run I see these things (username, password, folder in users) but they do not match the current run.  I have tried deleting and downloading rosbot again but no luck.


Phz65
Joined: 10/11/2015 - 09:57
Tue, 03/29/2016 - 08:19

I've been having this problem for a while, but I have two solutions. 

First, the problem for me usually happen when I try to reopen rosbot a *second* time when it's already running. So by making sure that I hit F7 in the game when I'm done or want to change settings fix this issue 95% of the time.

But sometimes, diablo crashes or rosbot crashes or whatever something happens and I can't F7 but rosbot is still running somewhere and I can't open a new one.

Fix #1 Ctrl-alt-delete, task maangement, close it down. It's usually named with some random letters. 
Fix #2 Sometimes #1 doesn't work, tells me it's protected or something, so I just reboot and it fixes it.

Hope it helps someone


KatziKasimir
MODERATOR
Joined: 04/16/2015 - 19:28
Tue, 04/05/2016 - 10:36 (Reply to #65)

@zalmoxis
Install the newest version of Net Framework (4.5) + SlimDX for D3Helper also you should install the Visual C++ Redistributable (2005,2008,2010,2012,2013) I had the same Problem and it foxed it for me.


I like cats come to Discord if you like them too.

damandd
MODERATOR
Joined: 01/04/2015 - 16:46
Tue, 04/12/2016 - 23:48

Windows did an automatic update today, now when I start RosBot exe the Bot UI opens fine, but D3 does not start. The limited user is still there and in the RosBot Global Settings folder with password (all this was setup automatically when 2.01 released and was working up until today). 

I did notice that my Disk Utilization was spiking to 99% but searching online I seemed to fix that by disabling Superfetch, Prefetch and BITS. Disk Utilization is back to normal.

But the RosBot exe is not opening D3 at all :/

UPDATE!
I did not get any errors with my issue, but I decided to try this https://www.ros-bot.com/forums/bot-support/201-solution-cannot-find-spec... and it fixed my issue. Again, Had Windows 10 before when 2.01 first came out. I had no issues. Windows, just today, did an automatic update, seemed like a big update, and that is when the issue of RosBot exe starting the Bot UI but would not launch D3. My limited user was still there and the info in the GlobalSettings folder was there.

I read the above linked info and saw that after the update my registry did not have the RegisteredOwner and RegisteredOrganization stings. I added these following the above link and it is now working again.

I think I did get a virus somehow(unrelated to RosBot) giving me some issues like spiking Disk Utilization and spiking CPU Usage. Also when I am in File Explorer and I mouse over the folders on the left my cursor rapidly changes from the normal arrow pointer to "waiting/busy" indicator. 


Please vote here to have a nearby Pylon or Shrine take priority.
https://www.ros-bot.com/suggestions/prioritize-pylons-396644

DiegoTK
Joined: 03/01/2016 - 17:26
Tue, 04/19/2016 - 19:52

Friends, my problem started today, the RoS-Bot when I click run the application simply closes, already removed from the computer and installed again and nothing. What can it be?


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Mon, 04/25/2016 - 11:54 (Reply to #68)

Sounds like an anti virus that starts considering the executable as a threat. At least, we know it happens with some anti viruses. Please make sure it's not the case on your side


NO support by private message.

Support must go through forums
Support - Beta

dreblin
Joined: 10/12/2015 - 15:20
Mon, 04/25/2016 - 16:11

WORKS AGAIN... dont know why

started the bot v2.01d the first time after the banwave. everything works fine...
now, 5hours later ill stated it again but getting an error msg :/
using win7 with VM10

Problemsignatur:
  Problemereignisname:    CLR20r3
  Problemsignatur 01:    FFMEVD61.exe
  Problemsignatur 02:    1.0.0.0
  Problemsignatur 03:    56e828a8
  Problemsignatur 04:    RoS-BoT-Merged
  Problemsignatur 05:    1.0.0.0
  Problemsignatur 06:    56e828a8
  Problemsignatur 07:    2331
  Problemsignatur 08:    1af
  Problemsignatur 09:    IZY1CSDWYSLAGMR4JJ4I0MKEFS3WX2G2
  Betriebsystemversion:    6.1.7601.2.1.0.256.48
  Gebietsschema-ID:    1031
  Zusatzinformation 1:    0a9e
  Zusatzinformation 2:    0a9e372d3b4ad19135b953a78882e789
  Zusatzinformation 3:    0a9e
  Zusatzinformation 4:    0a9e372d3b4ad19135b953a78882e789

ill renamed the ROS-BOT folder to extract data from d3. but i get this error msgs



[email protected]
DONATOR
Joined: 11/29/2014 - 18:12
Sat, 04/30/2016 - 09:51

windows must have had a new security update, after reading through the forums i saw that one person claimed the problems started with this update so i investigated further now what i had to do to get it working was allow the local user in the RosBotGlobalSettings.ini  file permisions for all application control it is blocked by default right click the d3 folder and hit security and edit permisions i also did this for the bot. now it launches fine.


xxvmarcvxx
Joined: 01/27/2016 - 22:19
Sat, 04/30/2016 - 11:00

Darn.
I think I've tried every thing in this thread except wiping the disk with no luck. That was even before the season was over, so I haven't played in a while. I stopped by today to try the new version but wondered if I should buy a key if Diablo still wasn't launching. I tried the last bit I found just above me about adding the account from the config file to the permissions of diablo and ros bot folders, it seemed like it could work. I then tried to launch the old bot as a test but was stopped at my expired license. So what the heck I'll just get the license, it's quite reasonabily priced and well supported. But still... no luck launching Diablo.
 


pufflol
Joined: 02/07/2016 - 14:52
Wed, 05/04/2016 - 23:16

Game will not start, I see the Diablo 3 start logo but the process clears itself and game does not begin. Have purchased licence, please advise.


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Thu, 05/05/2016 - 01:58 (Reply to #73)

Try launching the game as the ros-bot user (check <my documents>/ros-bot/globalsettings.ini for credencials)
Is it launching ?


NO support by private message.

Support must go through forums
Support - Beta

dsasdad
Joined: 09/26/2015 - 02:04
Thu, 05/05/2016 - 21:29

the bot is not run for me at all 


dsasdad
Joined: 09/26/2015 - 02:04
Thu, 05/05/2016 - 21:29

what can i do


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Fri, 05/06/2016 - 01:09 (Reply to #76)

Please create a separate report issue with a detailed description of what you've done


NO support by private message.

Support must go through forums
Support - Beta

salma05011988
Joined: 04/29/2016 - 19:57
Wed, 05/11/2016 - 07:57

after new version of ros-bot when try to open the bot its close the game and open new game on log in screen ... after log in it show that i dont have charcter and should start with level 0 charcter, if i open the game normally it work fine
and there is other topic i found in this website about someone face same issue and no answer .. please advice.

Hi all,

Excuse my English is not perfect. :-)

After the update to version 2.01 Rosbot I stopped working (I'm doing a mistake somewhere).

1. Start RosBot
2. I automatically start Diablo 3, you want me to login
3. After logging does not account for any character

When I run Diablo3 first, and only then RosBot, Rosbot ends the game and start the game again, but the result is the same as point third

Unfortunately, I never found the answer why when you start Rosbot do not have my character on an account.

Someone advise me what I need to do to rosbot operate as before version 1.2?

Thank you for your advice

 


corosou
DONATOR
Joined: 08/12/2015 - 22:45
Wed, 05/11/2016 - 11:30

I got it working on my vmware windows 10 by setting "compatibility mode: windows 8" on the diablo3.exe.

After running it in windows 8 compat mode, I switched it back to windows 10 and it works fine. Whatever windows 8 compat mode did seems to be permanent and to have resolved my issue with the game dying after rb attempted to start it.


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Wed, 05/11/2016 - 15:37 (Reply to #79)

NO support by private message.

Support must go through forums
Support - Beta

simpsonss
Joined: 05/09/2016 - 01:11
Fri, 05/13/2016 - 22:51

how do I disable the automatic initialization of d3 when we started the bot?

I do not like the bot close battle.net


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Sat, 05/14/2016 - 17:16

how do I disable the automatic initialization of d3 when we started the bot?

You cannot disable this. It's a prequisite for the limited user's method


NO support by private message.

Support must go through forums
Support - Beta

goesitduck
Joined: 02/22/2016 - 07:14
Sun, 05/22/2016 - 14:22

FYI: I just helped two of my friends with the 'game not starting' issue. The solution was to do the registry fix (RegisteredOwner, RegisteredOrganization).
https://www.ros-bot.com/forums/bot-support/201-solution-cannot-find-spec...

Neither of them got any error message ("Cannot find specified file"). Both use Win10 Home.
This also worked for me on my Win 10 Enterprise N VM.


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Sun, 05/22/2016 - 17:25 (Reply to #83)

Thanks for sharing that information


NO support by private message.

Support must go through forums
Support - Beta

funcz3st
Joined: 05/24/2016 - 18:46
Thu, 05/26/2016 - 11:37

hi ich habe das problem das ich den test lizens nicht nuzen kann warum er sagt mir immer das ich ros nei starten soll aber der bot nicht geht wegen dem test schlüssel was kann ich tun
 


hayabusadakedo
DONATOR
Joined: 10/29/2014 - 11:36
Wed, 06/08/2016 - 10:13

I'm having issue when i run bot.  It says 
"no mapping between account names and security ids was done iis""
then
System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo)
System.Diagnostics.Process.Start()
#kw(dJzlH=%8isCz\*MP4az-0#.()
#kw(dJzlH=%8isCz\*MP4az-0#.)(
yJkc-O?Nbw"?\&\.N)17f(\f\*)\\LF.()

Any solutions?


mr.testem
DONATOR
Joined: 07/06/2015 - 13:19
Thu, 06/16/2016 - 14:22

Suddenly it stopped working to when I start bot. It worked fine previously. Sinche 16th of June it does not work.
The computer was switched off during bot initialization. And after that, when I run a bot, it even cannot create a window for application. It does not start diablo. It does not write anything into log file. Just fails. The error is in Russian, I'm afraid it does not tell you anything. 
My question is, could some files be currapted? Can I delete all files that a bot can create? Where are locations of these files? Whant to clean the whole system and restart bot. 

NOTE: after some investigation I found that files inside of documents/ros-bot were currapted. 
Deleted the folder, restarted the bot, it recreated everathing, now it works fine.


mr.testem
DONATOR
Joined: 07/06/2015 - 13:19
Wed, 08/17/2016 - 02:14

I'm getting an excepion:
An exception thrown: переполнение арифметической операции
Which means, overflow arithmetic operation.

Bot starts diablo successfully, but when it tries to connect your server, this error appears.
I moved existing log files into a temp folder. Now, when bot starts, logs are not created.
I'm using the last ros-bot_2.04b version. But the same happens with the previous ros-bot_2.04_early_access version.


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Wed, 08/17/2016 - 02:16 (Reply to #88)

Those may be linked with some old pickits/scripts being corrupted
Try unlinking them until you find the faulty one


NO support by private message.

Support must go through forums
Support - Beta

Acky
Joined: 11/10/2015 - 00:49
Thu, 11/03/2016 - 07:06


http://imgur.com/Ic56pzv

Running into this issue, and can't for the life of me firgure out whats going on, I should have everything that needs to be up to date up to date.


tathra2550
Joined: 06/22/2015 - 12:17
Thu, 11/10/2016 - 18:56

how can i fix this running latest bot
---------------------------
Cannot process request because the process (1636) has exited.

   at System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)

   at System.Diagnostics.Process.Kill()

   at \&Fl_g8R~EHU^\[-RBJy\,=MEZ'".‫‪‭‮‏‏‫‎‎‏‏‎‫‏​‪‫‮‏​‍‮‬‏‭‮‬‭‮()

   at \&Fl_g8R~EHU^\[-RBJy\,=MEZ'".‫‪‫‫‎‪‪‪‎‮‫‪‬‮‫‍‎‏‭‎‬‭‏‬‭‬‌‍‭‍‮()

   at |t6u(?y=Q0$z\*;\*\](-\&~!i=q\..‪‎‏‮‬‪‬‬‬‍‮‪‪‎‫‎‬‏‫‏‮‪‮‏‬‮.‮‏‍‌​‏‎‬​‍‬‌‬​‍‌‍‏‬‬‬‌‍‮​‫‮()
---------------------------
OK   
---------------------------


pony65
DONATOR
Joined: 06/15/2015 - 05:37
Fri, 12/09/2016 - 05:29

Hey guys my bot seems to always get stuck at initilizing ROS-BOT when i click on start botting.

Windows 7 64bit
no anti virus

Thanks


cyaneyed
DONATOR
Joined: 08/24/2015 - 01:57
Fri, 12/09/2016 - 23:41

made a post for a bug report but nobody has replied.. i cannot get the bot to run on a different pc. it just sits at the title screen opening the profile window.


Icelance
DONATOR
Joined: 03/18/2015 - 14:09
Sat, 01/21/2017 - 10:36

hi, when i try to start a program and click on "bot botting" the program say "5t4yqfeb has stopped working" anyone have same issue ? Thanks

EDIT: Fixed simple restarting my pc


smile2me
Joined: 12/05/2015 - 11:33
Mon, 01/23/2017 - 05:52

Please help with launching the bot and game. please see screenshot below with errors
Diablo3 must be launched - when i launched D3 and start the botting, it closes the game and give the following error
cannot process request because the process (4292) has exited. at system.diagnostics.process.getprocesshandle(int32 access, booleanthrowifexited)
at system.dianostics.process.kill()...
my operating system is win 7

thankshttps://cdn.ros-bot.com/sites/default/files/u82534-files/1.png


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Mon, 01/23/2017 - 07:52

Please report in a separate thread indicating what error you have in windows events logs (if any)


NO support by private message.

Support must go through forums
Support - Beta

peckster22
Joined: 09/23/2016 - 02:31
Sun, 02/05/2017 - 22:48 (Reply to #96)

I get that too! let me know if you find a solution


kripton
Joined: 09/13/2015 - 11:47
Wed, 02/08/2017 - 17:59

Problem solved


kripton
Joined: 09/13/2015 - 11:47
Fri, 02/10/2017 - 05:09

;)


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Sat, 02/11/2017 - 05:12 (Reply to #99)

Please tell us how
This helps for upcoming similar issues


NO support by private message.

Support must go through forums
Support - Beta

zeromus
Joined: 05/04/2015 - 06:13
Wed, 03/01/2017 - 21:37

Доброе время суток
При запуске бота он выдает этот текстовый документ
===============================================

можете обнаружить хотя бы одно сочетание клавиш. Регистрация Начало работы
ToogleInventory : DIK_I
ToggleMap : DIK_TAB
ToggleWorldMap : DIK_M
ForceStandStill : DIK_LSHIFT
Skill1 : DIK_1
Skill2 : DIK_2
Skill3 : DIK_3
Skill4 : DIK_4
PotionButton : DIK_Q
TownPortalButton : DIK_T
ForceMove : -1
ShowItemsOnGroundKey : DIK_LMENU
CloseAllOpenWindows : DIK_SPACE

в ..()
в .()
в .(Булево )
в 5)6#х-J6c544Lv{55'Y19(5О@..()
в ..()
в системе.Резьбонарезной.Задачи.Задач.InnerInvoke()
в системе.Резьбонарезной.Задачи.Задач.Выполнить()

Операционная система Windows 10 X64 Подскажите что с нем не так Заранее спасибо за помощь
 


Topic locked

Advertisements

Advertisements