Bot Quitting Greater Rifts

Get your trial key

Live community: https://discord.gg/s39XdMV

Early access version available here

New user ? Check guides​ or ask the discord bot

botguy69
DONATOR
Joined: 03/26/2015 - 10:17
Fri, 01/22/2016 - 23:42 #1

So I assume this is an ongoing problem that we just have to live with? I've seen many posts on this issue with no real outcome.

I've watched the Bot quit greater rifts in various states of play:

1. right on entry, then quits and remakes
2. half way through
3. Just before RG

All games were doing very well on time ie farming greater rifts, not pushing for max.

I've been watching for a couple of hours over the last week, using various scripts, settings etc and have watched it quit the Grift 6 times. So there's obviously a lot more quitting going on when I'm not watching.

All are on invoker crusader but different set ups etc. I'm confident it's not a script issue.

Why would the Bot quit grifts???

Cheers

botguy69
DONATOR
Joined: 03/26/2015 - 10:17
Sat, 01/23/2016 - 04:12

I don't have any hard data to back this up, back I am noticing the Bot exiting grift's more and more often. Also saw the same with a regular rift before too.

Frustrating in Seasons, cuz I'm running rift then grift so don't have 1000's of keys like in NS.

I assume it's something to do with the 2.4 upgrade and reworked Bot as I never noticed this as often in 2.3. It was doing it then, but no where near as often as now.


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Sat, 01/23/2016 - 05:44

Please use the bug report button


NO support by private message.

Support must go through forums
Support - Beta

botguy69
DONATOR
Joined: 03/26/2015 - 10:17
Sat, 01/23/2016 - 06:09

The problem is, I've been using different scripts, different settings, and it occurrs in different areas so I really don't think a bug report will help as it's so wide occurring. It's more of a feeler post to see if other people are experiencing this as well.


novadragon
Joined: 01/21/2016 - 15:50
Sat, 01/23/2016 - 09:27

Yep me too
 


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Sat, 01/23/2016 - 09:28 (Reply to #4)

The problem is, I've been using different scripts, different settings, and it occurrs in different areas so I really don't think a bug report will help as it's so wide occurring. It's more of a feeler post to see if other people are experiencing this as well.

Didn't say it's a problem of script. But we need logs


NO support by private message.

Support must go through forums
Support - Beta

mctenny
DONATOR
Joined: 10/21/2015 - 11:10
Sat, 01/23/2016 - 13:51

Ok, I am able to reproduce one scenario that causing bot exit a GR once it was opened. But not sure if this is related to other folks' scenarios.

Steps to reproduce my case;
1. Complete a lower GR 30, then stop Rosbot. (Make the default level to 30 when you click on the Nephalem Obelisk)
2. Change the Rift setting in ROSBOT to let the bot run GR 55. And Start Rosbot.

Then you will see Rosbot begins to click on the "down arrow" from the list to choose a lower GR instead of GR55. The bot will then enter the GR and exit immediately. I have tried twice and the problem can be reproduced.

P.S. If I choose GR45 after GR30, everything will be fine. It seems the bot can't handle correctly if I jump up more than 20 GR levels.
 


botterd3
DONATOR
Joined: 08/08/2015 - 12:33
Sat, 01/23/2016 - 16:12

Happened to me also: bot entered the grift and left the game immediately.
Video: https://sendvid.com/qfbpxrvg
Here is the log: http://pastebin.com/8L4Upf76

One more case in the middle of the rift: https://sendvid.com/6uv2047w
Log: http://pastebin.com/vW7jR0LH

 


botguy69
DONATOR
Joined: 03/26/2015 - 10:17
Tue, 02/02/2016 - 02:15

Noticed 8 more grifts failed over a 20 minute period. This is upon entering grift, quits straight away. Have already filed bug report.


k3nshiro2
DONATOR
Joined: 10/04/2014 - 13:12
Thu, 10/05/2017 - 15:50

same here bot quit after enter in gr


ComMan
ROS BOT
Joined: 03/20/2014 - 17:34
Sat, 10/07/2017 - 03:48 (Reply to #8)

The first log is interesting. It somehow states that the bot seems to think that the bot thinks it is still in town
This may be linked with an issue we have detecting map changes

The second log is something quite classical. The bot sees a portal and then can't find it anymore, resulting in a fail
It is a completely different issue than the first log. We need to keep walking if the portal is not seen anymore (not that easy)


NO support by private message.

Support must go through forums
Support - Beta

phyton
Joined: 04/27/2019 - 07:28
Wed, 06/12/2019 - 04:23

Hello, I have the same problem.
It can reach 90%, and after it quit.
It is very emberassing.
It does it after 99% too and quit at boss.
Does anyone have some idea how to fix it?

 


Patsch74
Joined: 03/10/2018 - 16:32
Thu, 06/13/2019 - 03:07

simple fix: you (your bot) is too slow ... adjust the time your bot can stay in GR in your master profile


Advertisements

Advertisements