bot doesnt know how to use stash or book of cain sometimes.

Get your trial key

Live community: https://discord.gg/s39XdMV

3.022 is out

New user ? Check guides​ or ask the discord bot

TOBAYYY
DONATOR
Joined: 12/20/2014 - 20:56
Mon, 01/07/2019 - 22:42 #1

The bot will click on these things but i guess "miss them" and will be stuck in a loop of trying to go back to them but defaulting to a corner of the screen instead. Bot will get stuck and doesnt know what to do. I can stop the bot and get rid of stuff in inventory and it will work but afterwards it will break again after a few runs. I run the game in windowed(fullscreen) but still nothing. Tried in windowed, same results.

 

updated to new bot and still happened even on 3.013

Bot Version: 
3.014
Release Type: 
Public
Sequence Used: 
rift
Sequence Settings: 
[BotParameters]
DoGreaterRift = False
FastRift = False
HomeTown = Act1
FastGreaterRift = False
BreakAfterBossKilled = True
BreakAtRiftEnd = False
ExplorationDistance = 40
StayInGameProbability = 75
GreaterRiftLevel = 25
GemChoice = All
GreaterRiftKeyToKeep = 0
NoXpPoolDecision = NoChange
EmpoweredRift = False
QuitGRiftOnBoss = False
Custom Script Used: 
DH UE Multishot
Custom Pickit Used: 
base
FastMode Settings: 
Fast mode tolerance = 0
Minimum duration = 2500
Life limit = 50
Scan range = 45
Density limit = 15
Elite weight = 15
Minion weight = 10
Warden weight = 15
Goblin weight = 15
Normal monster weight = 1
Stuck time detection = 500
Avoidance Settings: 
AvoidAffixes = False
AvoidMonster = False
BigGuysDetectionDistance = 35
BigGuysDetectionLifeLimit = 100
EliteDetectionDistance = 16
EliteDetectionLifeLimit = 100
MonsterDetectionDistance = 14
MonsterDetectionLifeLimit = 80
ArcaneDectectionDistance = 30
ArcaneDetectionLifeLimit = 100
CreepMobArmDectectionDistance = 12
CreepMobArmDetectionLifeLimit = 100
PlagueDectectionDistance = 15
PlagueDetectionLifeLimit = 100
FrozenPulseDetectionDistance = 15
FrozenPulseDetectionLifeLimit = 100
MoltenExplosionDistanceAvoid = 25
MoltenExplosionDetectionLifeLimit = 100
MorluMeteorDistanceAvoid = 25
MorluMeteorDetectionLifeLimit = 100
MortarDistanceAvoid = 18
MortarDetectionLifeLimit = 100
OrbiterDetectionDistance = 10
OrbiterDetectionLifeLimit = 100
ThunderstormDetectionDistance = 15
ThunderstormDetectionLifeLimit = 100
FrozenDetectionDistance = 25
FrozenDetectionLifeLimit = 100
WormHoleDetectionDistance = 10
WormHoleDetectionLifeLimit = 100
DesecratorDetectionDistance = 6
DesecratorDetectionLifeLimit = 100
MagdhaFireFliesDistance = 10
MagdhaFireFliesDetectionLifeLimit = 100
GhomGasCloudDetectionDistance = 10
GhomGasCloudDetectionLifeLimit = 100
DiabloRingFireDetectionDistance = 10
DiabloRingFireDetectionLifeLimit = 100
DiabloBonePrisonDetectionDistance = 10
DiabloBonePrisonDetectionLifeLimit = 100
DiabloExpandingFireDetectionDistance = 10
DiabloExpandingFireDetectionLifeLimit = 100
ZoltunKulleTwisterDetectionDistance = 10
ZoltunKulleTwisterDetectionLifeLimit = 100
ZoltunKulleBubbleDetectionDistance = 15
ZoltunKulleBubbleDetectionLifeLimit = 100
ZoltunKulleFallingRocksDetectionDistance = 15
ZoltunKulleFallingRocksDetectionLifeLimit = 100
EmberMeteorsDetectionDistance = 20
EmberMeteorsDetectionLifeLimit = 100
RG10YCirclesDetectionDistance = 12
RG10YCirclesDetectionLifeLimit = 100
PerendiFallingRocksDetectionDistance = 20
PerendiFallingRocksLifeLimit = 100
RG20YCirclesDetectionDistance = 22
RG20YCirclesDetectionLifeLimit = 100
CorpulentsLifeLimit = 100
CorpulentsDetectionDistance = 17
DemonFlyerFireballsLifeLimit = 100
DemonFlyerFireballsDetectionDistance = 5
SandWaspLifeLimit = 100
SandWaspDetectionDistance = 5
Algorithm = FleeAwayFromFight
SafeZoneMaxSearchRadius = 50
AvoidanceMovetimeout = 500
DeactivateUnderConduit = False
DeactivateUnderShield = True
SafeZoneSearchRadiusDelta = 5
MinionDetectionLifeLimit = 100
MinionDetectionDistance = 5
Frequency Of Apparition: 
100%
Issue Description: 
The bot will ruin a few good rifts, then it will go into braindead mode. It will attempt to click on the book of cain but fail and be stuck in a loop of clicking on a place where the bot cannot move, therefor making the bot wait for XP timeout or me closing it manually. Will also have the same exact problem with trying to put stuff in the stash. I have cleared 4 stash tabs out so that is not the problem.
Reproduction procedure: 
close the bot, get rid of everything in my inventory except potion and start bot back up again.
Logs: 
https://anotepad.com/notes/nxw5ek
cyp123
MODERATOR
Joined: 12/26/2015 - 19:41
Mon, 01/07/2019 - 23:14

The following will assist you in optimizing your video and resolution settings in D3 for RoS-Bot:
https://www.ros-bot.com/guide/optimal-video-settings-and-d3prefs-1224299
The most important parts are the Game resolution and Windows Display Scaling. D3Prefs.txt edits are optional.

Tldr: set windowed, drag smallest. Disable scaling.


Need fast help? Join us in ros-bot discord channel
Select appropriate #support channel and explain your issue.

TOBAYYY
DONATOR
Joined: 12/20/2014 - 20:56
Tue, 01/08/2019 - 14:03

Did these things last night except for dragging it to smallest, just left it on windowed. Still had the problem. The bot ran all night but always timed out due to no XP. the bot *works* but its no where near opitmal, lots of flaws on my end i suppose. still getting stuck trying to open stash and ID legendaries and set items.
 


cyp123
MODERATOR
Joined: 12/26/2015 - 19:41
Tue, 01/08/2019 - 14:07

Did these things last night except for dragging it to smallest

O' really? How surprising. 

The instructions are not pick and choose what you like and don't like. 


Need fast help? Join us in ros-bot discord channel
Select appropriate #support channel and explain your issue.

TOBAYYY
DONATOR
Joined: 12/20/2014 - 20:56
Tue, 01/08/2019 - 21:23

https://imgur.com/a/dYwZXK4

since we decided to be a smartass, i decided to follow all of the instructions, and here we are again, stuck. How surprising. It seems as if simply changing the resolution would do ANYTHING. In the past, you would never have to do things like this, make your client all special and tweak it.

I understand keybinds, graphics settings maybe, and even the resoltion.

Anyways, maybe its just happening to me i dont know, but my hud disappears as well, i dont know if thats just a new addition but thats a thing im experiencing thjat may be causing the problem? I dont know the bot but it doesnt seem that would be causing issues.

 


cyp123
MODERATOR
Joined: 12/26/2015 - 19:41
Tue, 01/08/2019 - 21:41 (Reply to #5)

Well if we are being all smart about it - the resolution has been always recommended. Just because information has been ignored by some doesn't change it at all.

Well, HUD disappearing. Didn't care to mention that before? That is not normal procedure, you know. Alt+Z combination gets it back.

Might want to make a picture with full logs enabled.
Bot gui - global settings.
First options there deal with logging. Displays bunch of information.


Need fast help? Join us in ros-bot discord channel
Select appropriate #support channel and explain your issue.

TOBAYYY
DONATOR
Joined: 12/20/2014 - 20:56
Wed, 01/09/2019 - 13:02

https://imgur.com/a/bNJMeYZ

This was over night. I had to manually fix it twice, but not the same problem. as far as i can tell, the hud issue didnt happen all night, which i think it was was causing the bot to freak out? Not sure. Deaths and such i dont care for, but having to XP timeout so many times is kinda annoying. Its manageable. Before it wouldnt XP timeout, and it did it twice last night but i fixed it by giving my mouse a vigorous shake.


cyp123
MODERATOR
Joined: 12/26/2015 - 19:41
Wed, 01/09/2019 - 14:51

Check your keybinds. Bot itself lacks the ability to lose your hud, but combination of Alt+Z can remove the hud.
So if bot has some sort of keybind set to Alt and another one to Z - that can lose your hud.
Or simply reset keybinds, set Force Move to C

Now, the picture you have does show that bot THINKS it is in town and that the rift portal is closing. It did a town run (salvaged etc) and now it's just waiting for rift to close, but rift will never close since it's not completed.
Interesting.

Could always use RBA for forced restart ot bot+game.
https://www.ros-bot.com/forums/general-discussion/rbassist-bot-schedulin...


Need fast help? Join us in ros-bot discord channel
Select appropriate #support channel and explain your issue.

TOBAYYY
DONATOR
Joined: 12/20/2014 - 20:56
Thu, 01/10/2019 - 15:31

Hud problem fixed. Pretty massive problem last night, same thing kinda. When i had it in the 800x600 windowed mode, it was somehow clicking stuff in the background, my applications. This morning i had over 100 notepads open and almost 200 internet explorer windows open. While i can just close them, the bot shouldnt be clicking off of the screen. I switched the bot over to another monitor with no applications in the background and i think the problem was fixed, but the bot had hours of downtime last night cause there was notepads and stuff in the way.

That isnt as related to the problem, but another one is he actually got stuck on the stash, like running back and forth right next to it. fixed it by manually clicking on the stash but figured id bring it back up.


cyp123
MODERATOR
Joined: 12/26/2015 - 19:41
Thu, 01/10/2019 - 16:14

Your screen is not dragged to smallest size.
Or you have display scaling.
Only way for it to click outside of bounds.

Set windowed. Take any of 4 corners. Drag smallest. Make sure no display scaling is present on your system.
VM - same rule.


Need fast help? Join us in ros-bot discord channel
Select appropriate #support channel and explain your issue.

Advertisements

Advertisements